PHP音乐分享社交平台 Deepsound v1.5.0

源码简介
DeepSound是一个音乐分享脚本,DeepSound是创建自己音乐网站的最佳方式!
DeepSound快速、丰富、安全,并将定期更新。
它和wowonder、playtube、Flame、Quickdate还有PixelPhoto都是一个作者开发的,使用起来有种很熟悉的感觉。
DeepSound 第三方主题模板 Soundify
在线演示
功能特性
上传音乐:从您的设备上传任何歌曲,并与其他用户在线分享。
Wave Generator:上传歌曲后,系统会为每首歌曲生成实时波形。
高性能:DeepSound可以轻松处理任意数量的歌曲,具有极高的性能和速度。
WoWonder集成:只需点击一下,用户就可以使用WoWonder社交网络登录您的网站。
销售歌曲:用户可以向其他用户销售歌曲。
用户配置文件:用户可以创建自己的配置文件并上传未下载的音乐。
SEO友好:SEO友好的链接,和HTML代码,谷歌会喜欢!
强大的管理面板:管理设置,视频,设计,以及更容易从我们的管理面板。
强大的用户界面:美观现代的设计。
pro系统:用户可以通过订阅脚本pro包中的一个来获得最重要的功能。
仪表板:用户可以从自己的仪表板查看最新歌曲的静态信息。
以及更多的功能
系统需求
PHP 5.5 or Higher.
MySQLi.
GD Library.
mbstring.
cURL.
allow_url_fopen.
MySQLi.
GD Library.
mbstring.
cURL.
allow_url_fopen.
更新日志
https://docs.deepsoundscript.com/#idocs_changelog
v1.5 [22/12/2022]
添加 能够从电话用户的“设置”页面更新个人资料图片。
添加 火山的新主题。
添加 能够收听所有喜爱的歌曲。
添加 按日期筛选事件的功能。
添加 能够从管理面板自定义网站默认颜色 - >设计设置。
更新 谷歌加上页脚与Instagram的链接
更新 上传系统,现在FFMPEG在后台运行,用户可以在上传歌曲的同时浏览网站。
修复 如果未提交上传的歌曲,它们将永久保留在服务器上。
修复 10+ 小错误。
v1.5 [22/12/2022]
添加 能够从电话用户的“设置”页面更新个人资料图片。
添加 火山的新主题。
添加 能够收听所有喜爱的歌曲。
添加 按日期筛选事件的功能。
添加 能够从管理面板自定义网站默认颜色 - >设计设置。
更新 谷歌加上页脚与Instagram的链接
更新 上传系统,现在FFMPEG在后台运行,用户可以在上传歌曲的同时浏览网站。
修复 如果未提交上传的歌曲,它们将永久保留在服务器上。
修复 10+ 小错误。
下载地址&安装方法
[payhide-deepsound]下载地址
https://pan.seeoss.com/s/kaohn
https://mir.cr/P2OWWGTR
安装、升级方法
安装
1、下载文件,解压缩后将Script文件夹内的内容上传到服务器。
2、建立mysql数据库
3、打开yourdomain.tld/install 执行安装。
4、同意许可协议、系统环境检查、来到下一步。
5、安装代码保持默认即可,已由reishi破解,填写数据库信息以及网站名称、管理员信息,完成安装。
6、nginx用户伪静态规则使用下面的规则
根目录下的nginx.conf(官方提供)似乎不起作用。
升级
1、注意:升级必须是逐个版本升级,不能跳跃式升级,例如你现在的版本是1.4.0,不能直接升级到1.4.6,必须先升级到1.4.1...一直到1.4.6.
2、这里举1.4.6升级到1.4.7的方法:首先还是备份,避免升级失败造成原站无法访问。打开Update Guide\v1.4.6\Script文件夹,将下面的内容连同Update Guide\v1.4.7\update.php 全部上传覆盖到服务器的1.4.6中,然后打开yourdomain.tld/update.php 执行升级。
[/payhide]https://pan.seeoss.com/s/kaohn
https://mir.cr/P2OWWGTR
安装、升级方法
安装
1、下载文件,解压缩后将Script文件夹内的内容上传到服务器。
2、建立mysql数据库
3、打开yourdomain.tld/install 执行安装。
4、同意许可协议、系统环境检查、来到下一步。
5、安装代码保持默认即可,已由reishi破解,填写数据库信息以及网站名称、管理员信息,完成安装。
6、nginx用户伪静态规则使用下面的规则
if (!-d $request_filename){
set $rule_0 1$rule_0;
}
if (!-f $request_filename){
set $rule_0 2$rule_0;
}
if ($rule_0 = "21"){
rewrite ^/(.*)$ /index.php?path=$1 last;
}根目录下的nginx.conf(官方提供)似乎不起作用。
升级
1、注意:升级必须是逐个版本升级,不能跳跃式升级,例如你现在的版本是1.4.0,不能直接升级到1.4.6,必须先升级到1.4.1...一直到1.4.6.
2、这里举1.4.6升级到1.4.7的方法:首先还是备份,避免升级失败造成原站无法访问。打开Update Guide\v1.4.6\Script文件夹,将下面的内容连同Update Guide\v1.4.7\update.php 全部上传覆盖到服务器的1.4.6中,然后打开yourdomain.tld/update.php 执行升级。
安装截图

文章由 reishi 于 2024-02-28, 12:46 编辑
原因:更新版本到v1.5.0